Hayling Island

Hayling Island

Monday, November 14, 2016

Now to repair the SM-4100 I need the scope working..

.. and what happens? I power up the scope (HP 54502A) .. and it shuts down 10 seconds later.

It's a power supply issue. Apparently quite well known on this family of scopes. There are no like-for-like replacements around. Fortunately it does seem to work OK for 10 seconds, so I hope that the PSU going south hasn't killed the motherboard. I have a schematic for the PSU ...

There are some obvious weak points, which I have checked. What I really need to do is to break the feedback loop and fire up an external PSU to see where the issue is. Of course I would need a scope.

However, I have found in the schematic, hiding away, a crowbar circuit. It's a small bit of gizmodery on the voltage regulator board that has a thyristor in the middle; thyristors have the characteristic that once switched on, they only switch off again when the current through them drops to near zero. This one is wired so that the +5v and the +15v are shorted to ground if any of the output voltages exceed some threshold. The shutdown behaviour must be the crowbar doing its job .. so now I have the PSU disconnected from the scope, a dummy load of half a dozen 0.33 ohm resistors in series on the +5v; I am going to disconnect the thyristor, and see which of its inputs is causing it to switch (and it seems to be watching all of the rails in one way or another; +3.5v, +5.15v, +12v, -5.2v, -12v ... ) 
Disconnected the crowbar. It's no better, so it is not the crowbar doing it. Next theory is that it is a capacitor on the secondary side which is absorbing lots of current. Firing up the supply, and touching all of the capacitors - can't find a hot one. Not sure where to go without a scope ..

No comments:

Post a Comment