Hayling Island

Hayling Island

Monday, February 13, 2017

Fixed Scope!

The power supply issue on the HP 54502A eventually succumbed to my repair type ministrations.

I had found a bunch of capacitors in the ageing power supply that needed replacement. 12 in all, all 2200uf 35v that I bought a bulk of Panasonic replacements for. That, and a test load brought the power supply back to something that worked a bit, for a while.

The thing with SMPS is that they are a nest of feedback loops. Especially early ones like this, using discrete componentry. After having reminded myself of what a UJT oscillator looks like, I found that the feedback for the +5v from secondary to primary was way out of whack.

That took me to a circuit in the secondary that compared the +5v and the -5v rail in a long tailed pair. -5V being generated by a linear regulator from the -12v, itself a linear regulator off a separate secondary.

Trouble is, with all this feedback going on, the secondary outputs all look wrong, so how to find out what was working? The trick in the end turned out to be switch on, run down all of the outputs to see if they start off ok or not. And guess what? The -12v that fed the -5v that was compared to the +5v to drive the feedback to the oscillator never got bigger than -6v.

So I drove the -12v regulator from an external 15v power supply, to see if it worked by itself. Still faulty! Getting warmer .. but it is only a few components. Swapped all the capacitors. No change. Measured resistors (by probing them near the body from the top) no problems. Hmm ...

Then noticed some burning or black stuff on one leg of two resistors - near the big capacitors on the 5v I had replaced. I hadn't noticed that one of the caps had leaked. I removed the resistors, used a Dremel to remove the black stuff and clean up the PCB as much as possible, replaced the resistors ..